Foopets | Real Virtual Pets Online

Member Login

My pet won't load...

Medium

Hello,
My pet when I click on the play option won’t load. I tried waiting for the loading screen to be finished and even after an hour or two it still has the loading screen. I was sure to enable flash on my browser (Chrome) and I cleared cookies and cache on my web browser. However, it still doesn’t work. When I log out, I am able to see the pets for adoption when you go to make a new account. However, when I log back in the problem persists.

Medium
Useful 5

If you use Chrome, look at the top left of your browser bar.
Click on the circled i
A drop down box will open then look where it says ,“flash” to the right you will see where it says,“allow” click on that.
Another drop box will open and click on where it says allow, click on allow and
NOT defaut.
Then click on the little i with the circle around it again.
another drop box will drop down.
Click on the box that says reload.

You will have to do this each time Chrome updates.

Medium

Better to just use Opera. All you have to do there is click on yes to adobe when the load screen pops up.

Medium

I’ve already done that and it still won’t load. @Remsie

Medium
Useful 5

If that did not help then using a different browser, as Geo-Wilcox stated, may be your best avenue to take.

Medium

I did it and it worked for me. I will see tomorrow if it has reset itself.

Medium
Useful 15

None of the browsers I had installed worked. I installed Opera and it worked. Thank you for your help!

Medium

Good, seems very strange that different browsers allow different things. I can’t take pictures on Chrome or Opera but can on Firefox.